Payment Processor Issues: First Data
Incident Report for Olo
Resolved
This incident has been resolved.
Posted Jun 03, 2020 - 22:34 EDT
Monitoring
We have implemented a fix and we are seeing First Data transactions return to normal. We continue to monitor the situation.
Posted Jun 03, 2020 - 22:23 EDT
Identified
We're detecting elevated errors processing payments through First Data. Ordering may be affected at locations using First Data as their payment provider.
Posted Jun 03, 2020 - 21:15 EDT
This incident affected: Partners (Payment Processing Partners).