Payment Processor Issues: Paymentech
Incident Report for Olo
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 24, 2018 - 19:55 EDT
Identified
We're detecting elevated errors processing payments through Paymentech. Ordering may be affected at locations using Paymentech as their payment provider.
Posted 3 months ago. Jun 24, 2018 - 19:20 EDT
This incident affected: Partners (Payment Processing Partners).