Payment Processor Issues: First Data
Incident Report for Olo
Resolved
This incident has been resolved.
Posted 11 months ago. Jul 14, 2017 - 07:20 EDT
Identified
We're detecting elevated errors processing payments through First Data. Ordering may be affected at locations using First Data as their payment provider.
Posted 11 months ago. Jul 13, 2017 - 23:41 EDT
This incident affected: Payment Processing Partners.