Delayed Invoicing Automatic Charges

Incident Report for Olo

Resolved

This incident has been resolved.
Posted May 27, 2025 - 11:43 EDT

Update

A fix has been identified and our billing service provider estimates that charges will resume next week.
Posted May 23, 2025 - 11:31 EDT

Identified

We are experiencing a service disruption with our billing service provider that is causing customers set up with automatic payments to not be charged for Olo invoices. Charges may be delayed until this is resolved. We are working with our provider to resolve the issue. We will provide updates as we get more information.
Posted May 22, 2025 - 14:08 EDT
This incident affected: Olo Invoicing.