Payment Gateway Issues: FreedomPay

Incident Report for Olo

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 12:41 EDT

Monitoring

We're seeing Freedompay transactions return to normal and continue to monitor the situation.
Posted Mar 11, 2026 - 12:32 EDT

Investigating

We're detecting elevated errors processing payments through FreedomPay. Olo ordering and POS payments may be affected at locations using FreedomPay as their payment gateway.
Posted Mar 11, 2026 - 12:15 EDT
This incident affected: Olo Pay (POS) and Partners (Payment Processing Partners).