Payment Processor Issues: FreedomPay

Incident Report for Olo

Resolved

This incident has been resolved.
Posted May 02, 2025 - 14:06 EDT

Monitoring

We are no longer seeing errors with FreedomPay transactions and are continuing to monitor.
Posted May 02, 2025 - 13:50 EDT

Investigating

We're detecting elevated errors processing payments through FreedomPay. Ordering may be affected at locations using FreedomPay as their payment provider.
Posted May 02, 2025 - 13:39 EDT
This incident affected: Partners (Payment Processing Partners).