Payment Processor Issues: Payeezy

Incident Report for Olo

Resolved

This incident has been resolved.
Posted May 02, 2025 - 14:35 EDT

Monitoring

We are seeing Payeezy transactions return to normal and continue to monitor the situation.
Posted May 02, 2025 - 14:21 EDT

Investigating

We're detecting elevated errors processing payments through Payeezy. Ordering may be affected at locations using Payeezy as their payment provider.
Posted May 02, 2025 - 13:59 EDT
This incident affected: Partners (Payment Processing Partners).