Menu Management Processing Delays

Incident Report for Olo

Resolved

This incident has been resolved.
Posted Feb 10, 2025 - 11:30 EST

Update

We are seeing processing times returning to normal, and will continue to monitor the situation.
Posted Feb 10, 2025 - 11:12 EST

Monitoring

We are actively monitoring delays in processing menu updates. Changes may not immediately be reflected in the menu.
Posted Feb 10, 2025 - 11:02 EST
This incident affected: Menu Services.