Reporting Delays & Issues with Catering features within Dashboard

Incident Report for Olo

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:52 EDT

Monitoring

Issues with a downstream vendor are stabilizing, we will continue to the monitor results and provide updates as they become available.
Posted Oct 20, 2025 - 17:09 EDT

Update

We are still observing delays in reporting and loading of Catering accounts within Dashboard due to issues with a downstream vendor, we will provide updates as they become available.
Posted Oct 20, 2025 - 15:20 EDT

Identified

We are still observing delays in reporting and loading of Catering accounts within Dashboard due to issues with a downstream vendor, we will provide updates as they become available.
Posted Oct 20, 2025 - 12:16 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 10:45 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 10:43 EDT

Investigating

We are investigating a delay in reporting and loading of Catering accounts within Dashboard due to issues with a downstream vendor, we will provide updates as they become available.
Posted Oct 20, 2025 - 09:42 EDT
This incident affected: Dashboard and Reporting.