We have processed the backlog of menu changes and are seeing job times return to normal. We will continue to monitor the situation.
Posted Feb 13, 2025 - 15:11 EST
Update
We are continuing to process a large backlog of menu updates. Changes may not immediately be reflected in the menu.
Posted Feb 13, 2025 - 13:42 EST
Update
We have provisioned additional capacity for processing menu changes and are continuing to process through the backlog of changes. Changes may not immediately be reflected in the menu.
Posted Feb 13, 2025 - 12:21 EST
Update
We are continuing to process a large backlog of menu updates. Changes may not immediately be reflected in the menu.
Posted Feb 13, 2025 - 11:40 EST
Monitoring
We are actively monitoring delays in processing menu updates. Changes may not immediately be reflected in the menu.
Posted Feb 13, 2025 - 10:55 EST
This incident affected: Reporting and Menu Services.